Générez vos codes barre dans Google Sheets

4539 4

Jean-Paul JOURDAN et Stéphane GIRON vous livrent une petite astuce pour générer vos codes barre directement dans Google Sheets.

Cette astuce utilise la fonction image() et le site de génération de codes (barcodesinc.com)

Une copie du fichier exemple est disponible par ici : https://goo.gl/TnNN9G

copie_de_generateur_code_barre_-_google-sheets

Dans la première colonne, vous rentrez simplement le code à générer. La seconde colonne permet de générer avec cette formule le code « générateur » :

=CONCATENER(A2;DROITE(10DROITE(STXT(A2;1;1)+STXT(A2;3;1)+STXT(A2;5;1)+STXT(A2;7;1)+STXT(A2;9;1)+STXT(A2;11;1)+3*(STXT(A2;2;1)+STXT(A2;4;1)+STXT(A2;6;1)+STXT(A2;8;1)+STXT(A2;10;1)+STXT(A2;12;1)))))

La colonne n°3 permet ensuite d’obtenir le code barre C128B à partir du site (barcodesinc.com), la formule insérée est :

=SI(A2=«  »;;image(« http://www.barcodesinc.com/generator/image.php?code= » & B2 & « &style=197&type=C128B&width=200&height=100&xres=1&font=3 »; 3))

Enfin la colonne n°4 vous indique le code barre au format EAN à l’aide de la fonction

=image(« http://www.codebarre.be/phpbarcode/barcode.php?code= »&CNUM(B2)&« &encoding=EAN&scale=4&mode=png »;4;100;200)

Vous pouvez trouver d’autres astuces sur l’excellente communauté G+ Google Sheets francophone.

 

Si vous avez trouvé une faute d’orthographe, veuillez nous en informer en sélectionnant le texte en question et en appuyant sur Ctrl + Entrée .

Jean-Paul JOURDAN

Jean-Paul JOURDAN

Consultant formateur certifié Google Apps

4 commentaires

  1. Avatar

    Merci pour ce billet.
    J’ai testé avec l’isbn d’un livre (13 chiffres) et si j’obtiens bien le code barre au format C128B, la colonne EAN reste vide. Vous auriez une solution ?

    1. Avatar

      Non pas trouvé.. j’aimerai bien car je gagnerai un temps fou !

  2. Avatar

    Bonjour, il y a un chiffre en trop dans le code barre généré… avez la solution svp ??

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Rapport de faute d’orthographe

Le texte suivant sera envoyé à nos rédacteurs :