Google Sheets : additionner des durées

8

Peut-être vous est-il arrivé d’avoir besoin d’additionner des durées ?

Prenons tout d’abord cet exemple : voici une liste de formations à distance réalisée, la colonne C comprend la durée de chaque module. Je souhaite additionner le temps passé. Dans la cellule C29, j’obtiens 22:00, en réalité le total est de 24H + 22H soient 46H au lieu de 22 😉

 

 

Pour y parvenir, il convient alors de convertir le format de la colonne C et d’exprimer les heures en centièmes, en minutes ou en heures au format hh.mm.ss :

 

Voici un accès à ce fichier pour bien comprendre, dans cet exemple, il faut effectivement passer la colonne C en centièmes et la colonne E en heure au bon format avec la formule =D2/24 et changer le format dans l’icône 123.

 

 

 

Si vous avez trouvé une faute d’orthographe, veuillez nous en informer en sélectionnant le texte en question et en appuyant sur Ctrl + Entrée .

8 Commentaires

  1. Bonjour,
    je débute sur Sheets, et app Script.
    je cherche à afficher une durée négative. Je m’explique: je voudrais créer un planning hebdomadaire de mon occupation professionnelle et comptabiliser les heures supplémentaires.
    8:30 -> 9:30 : activité 1, durée : 1h (dans la case (A1))
    9:30 -> 11:00 : activité 2, durée : 1h30 (Dans la case A2)
    et ainsi de suite.
    Je somme les durées en fin de journée.
    Sur une journée type de 8h (valeur inscrite dans la cellule I5), si je preste 9h, j’ai une heure de bonus. Dans ma case de calcul des heures sup, j’ai écrit =SOMME(« A1:A8 ») – I5
    Par contre si je ne fais que 7h, j’ai une heure de malus. Sauf que SOMME(« A1:A8 ») – I5 revient à faire 7:00 – 8:00 = 23:00
    Comment pourrais-je avoir 7:00 – 8:00 -> -1:00
    Cela me permettrait en fin de semaine de sommer toutes les heures sup et d’avoir mon total correct.
    Merci pour votre aide.
    François

  2. Bonjour Thierry je suis à la recherche d’une fonction ou formule permettant de créer un chronomètre projet, qui permettrait au début d’un dossier de lancer le chronomètre de faire pause et redémarrer puis faire stop. L’objectif serait de calculer le temps réel d’un projet. Y a t’il quelque chose ?

  3. Bonjour
    Cette manipulation est elle réalisable sur l’application androïde ?
    Je cherche à calculer un salaire mais je n’arrive pas à passer mon nombre d’heure en centième sur l’application pour ensuite le multiplier par le taux horaire…
    En vous remerciant.

  4. Hello! Sur Google Sheets, il est maintenant possible de choisir le format « Durée » en cliquant sur 123, et donc d’additionner les horaires en un clic. Mais un grand merci pour le tips du 123, sans quoi je n’aurais jamais trouvé cette option 🙂

LAISSER UN COMMENTAIRE

S'il vous plaît entrez votre commentaire!
S'il vous plaît entrez votre nom ici

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.