Gsheet : calculer la distance entre deux adresses

Dans un premier temps, il vous suffit d’ouvrir ce document https://goo.gl/4pw3qp Une copie sera générée automatiquement dans votre Drive, c’est déjà magique !

Ensuite le but de votre mission si vous l’acceptez est de mettre des villes ou adresses précises dans les colonnes A & B

t_Gsheet-calculer-la-distance-entre-deux-adresses-.jpg

Dans la colonne C, la distance se calcule automatiquement via un Google Scripts et vous trouvez l’itinéraire dans la colonne D. Encore plus rapide que Google Maps pour l’occasion.

Les cas d’usage sont nombreux, de mon côté, je vais l’utiliser pour du démarchage de mairies et calculer la distance entre une mairie et la ville de Lille mais aussi pour calculer les frais de déplacement pour aller sur une prestation ou formation.

Dans la colonne D, après un clic l’itinéraire ressemble à ceci :

t_Gsheet-calculer-la-distance-entre-deux-adresses-.jpg

Jean-Paul a pensé à tout et a rajouté un bouton itinéraires dans les menus de Gsheets

Gsheet-calculer-la-distance-entre-deux-adresses-.jpg

Voici à quoi cela ressemble une fois le numéro de la ligne renseignée :

Gsheet-calculer-la-distance-entre-deux-adresses-.jpg

Bon voilà, il n’y a plus qu’à… Et vous, qu’allez-vous faire avec ce script ? N’hésitez pas à mettre un commentaire sous cet article et à vous abonner à la newsletter hebdo du lundi pour recevoir le plein de nouveautés Google !

 

Notez cette information
[Total: 2 Average: 5]
Thierry

Thierry

Thierry VANOFFE, consultant, formateur, coach G Suite. Passionné et fasciné par Google, ce blog me permet de partager cette passion et distiller tutos, trucs, astuces, guides sur les outils Google. N'hésitez pas à me solliciter pour vos formations en ligne ou en présentiel.

17 comments

  1. Bonjour
    intéressant ! est il possible de d’insérer des étapes ?

    Merci .

  2. bonjour

    Probablement une astuce toute bête mais le calcul drivingdistance ne fonctionne pas sur ma feuille…

  3. Merci Thierry c’est Génial ce que tu fais je te béni ! Trop pratique pour faire les calcules d’une tournée
    Je cherche une astuce pour faire la même chose avec Google agenda (je n’ai pas trouvé si ça éxiste déjà) Voir mon post dans google apps les experts du 23 Juin 2016

    1. La tournée des bars ? N’hésite pas à m’envoyer des articles, je te mettrai auteur du blog 😉

  4. Bonjour Thierry, merci beaucoup pour ce script.
    Sais-tu si c’est possible de le modifier légèrement pour obtenir la distance entre deux code postaux ?
    Merci !

  5. Bonjour, l’idée de ce fichier excel est vraiment très intéressante. Toutefois, une fois chargé dans le google drive, les distances pour les deux exemples ne s’affichent pas. Dans la cellule C2 la formule est : =iferror(drivingdistance(A2,B2))
    Est-ce normal que rien ne s’affiche? Pourtant je n’ai fait que télécharger le document excel rien de plus pour l’instant.
    Vous remerciant pour votre retour,
    Virginie

    1. Remplace le mot Excel de microsoft par Google Tableur et ça ira mieux 😉

      1. bonjour Thierry j’ai le meme probleme je ne comprend pas ta reponse

  6. Bonjour,
    J’ai appliqué les scripts et formules proposés, et le résultat fonctionne …. de temps en temps.
    A certains moments de la journée, la distance s’affiche, à d’autres elles ne s’affiche pas.
    Mon fichier Sheet contient 31 onglets, et dans chaque onglet 225 cellules avec la formule suivante :
    =SI(G4″”;SI(R4″”;ARRONDI(SIERREUR(drivingdistance(R4;G4))/1000;0);””);””)
    Mon idée est de faire appel à la fonction drivingdistance uniquement si l’origine et la destination sont renseignées, soit donc environ 50 appels de la fonction par jour.
    Mon idée est-elle correcte ou faut-il procéder autrement ?
    Merci pour votre aide

    1. la formule s’est mal affichée :
      =SI(G4 “”;SI(R4″”;……

  7. Bonjour,

    j’ai le même soucis que les commentaires précédents, l’affichage des distances est aléatoire (1 fois sur 10)
    il trouve bien le trajet entre deux adresses, je relance exactement le même calcul entre les deux mêmes adresses, il n’arrive plus à trouver de résultat…

  8. bonjour
    pratiquement ce dont j’avais besoin, à tous les coups je récupère le lien pour l’itinéraire par contre pas toujours le nombre de kilomètres ? y a t’il une particularité ou une syntaxe à respecter pour indiquer les villes ou les adresses ?
    Merci d’avance

  9. Bonjour Thierry,

    Tout d’abord merci pour cet article !
    Ce que je veux faire est simple mais je me perd dans ton code…
    Je cherche juste à retourner dans la colonne Z la distance à pied en D et H…
    Impossible de faire fonctionner la code 🙁

    Merci d’avance,

    Tao

  10. Bonjour

    Merci beaucoup pour cet outil !
    Est-il possible de calculer une durée de trajet ? (j’ai essayer de remplacer drivingdistance par drivingtime … mais bon j’imagine que c’est pas aussi simple ! )
    Idem avec des trajet en transport en commun ?

    Merci beaucoup

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Share This

Share This

Share this post with your friends!