ALL Google Sheets

Gsheets : extraire les domaines d’une liste d’emails

Ecrit par Thierry

Partant d’un besoin simple : connaître la répartition des adresses email par domaine pour les 950 abonnés de ma newsletter, une petite formule m’a aidé à trouver la réponse et à réaliser un TCD très rapidement.

Partons sur cette base de données. Les personnages et les situations de ce récit étant purement fictifs, toute ressemblance avec des personnes ou des situations existantes ou ayant existé ne saurait être que fortuite.

Dans la colonne B, je souhaite mettre les domaines avec une formule, comme ceci :

Comment faire ?

Le résultat de cet exercice proposé à l’excellent Jean-Paul JOURDAN est la fonction suivante :

=SIERREUR(arrayformula(DROITE(A2:A;(NBCAR(A2:A)CHERCHE(« @ »;A2:A)))))

Explications :

=SIERREUR : S’il ne s’agit pas d’une valeur d’erreur, affiche le premier argument. Sinon, affiche le deuxième argument s’il est présent, ou une valeur vide si cet argument est absent. Cela me permettra d’avoir une case vide plutôt qu’un code erreur si la colonne A n’est pas composée d’un email.

Ce qui fait plus classe qu’un #VALEUR par défaut :

Intéressons-nous maintenant à la seconde fonction de cette formule, le fameux :

=ARRAYFORMULA qui permet d’afficher des valeurs issues d’une formule de tableau sur plusieurs lignes et/ou colonnes, et d’utiliser avec des tableaux des fonctions ne prenant pas en charge ces derniers. En gros, vous mettez votre formule ArrayFormula en B2 et cette fonction est recopié jusqu’en bas du tableur, donc si des emails se rajoutent, la colonne B se complète automatiquement. Magique non ? Voici une petite animation si les explications ne sont pas assez claires :

Enfin pour la dernière partie de la formule, le concept est le suivant avec ces 3 fonctions de la famille texte :

  • =NBCAR : Affiche la longueur d’une chaîne.
  • =DROITE : Affiche une sous-chaîne à partir de la fin d’une chaîne donnée.
  • =CHERCHE  : Affiche la position à laquelle une chaîne est détectée pour la première fois dans un texte. Ici on va chercher le @

Ce qui donne pour =(DROITE(A2:A;(NBCAR(A2:A)CHERCHE(« @ »;A2:A))) : calcule moi le nombre total de caractères dans l’email, trouve la place du @ et soustrait et affiche les caractères totaux à droite moins ceux jusqu’à la position du @.

Pas mal non ? Et vous quel combo de formules Google Sheets auriez-vous utilisé pour ce besoin ?

Bon sinon, sans surprise voici le top 15 des domaines les plus abonnés à ce blog 😉 Sur un total de 948 abonnés :

 

 

 

 

Notez cette information
[Total: 0 Average: 0]

A propos de l'auteur

Thierry

Thierry VANOFFE, consultant, formateur, coach G Suite.
Passionné et fasciné par Google, ce blog me permet de partager cette passion et distiller tutos, trucs, astuces, guides sur les outils Google.
N'hésitez pas à me solliciter pour vos formations en ligne ou en présentiel.

1 commentaire

Laisser un commentaire

Abonnez-vous à la newsletter hebdo du lundi.

Recevez chaque lundi les 7 news, trucs et astuces sur G Suite.

L'abonnement à la newsletter a été réalisé avec succès !

Share This

Share This

Share this post with your friends!