Google Sheets : corriger l’erreur #N/A avec sierreur

495 1
L’erreur #N/A indique généralement qu’une formule ne trouve pas ce qu’elle est censée rechercher. L’erreur #N/A survient le plus souvent avec les fonctions RECHERCHEV, RECHERCHEH ou EQUIV si une formule ne trouve pas une valeur référencée. Par exemple, la valeur recherchée n’existe pas dans les données sources.

Dans le cas présent, il n’y a aucune valeur « Banane » dans la table de choix. La fonction RECHERCHEV renvoie donc une erreur #N/A.

Solution : vérifiez que la valeur recherchée existe dans les données sources ou utilisez un gestionnaire d’erreurs tel que SIERREUR dans la formule. Par exemple, =SIERREUR(FORMULE();0) a la signification suivante.

SIERREUR (IFERROR)

S’il ne s’agit pas d’une valeur d’erreur, affiche le premier argument. Sinon, affiche le deuxième argument s’il est présent, ou une valeur vide si cet argument est absent.

Exemple d’utilisation:  =SIERREUR(A1;"Erreur dans la cellule A1")

Vous pouvez utiliser “” pour ne rien afficher ou votre propre texte : =SIERREUR(FORMULE();”Message d’erreur ici”)Dans notre cas :=iferror(VLOOKUP(A2;$D$1:$E$4;2;FALSE);“référence non trouvée”)

Ce qui donne :

Dédicace à Fabrice Faucheux pour cette idée d’article. Maintenant vos recherchev seront encore plus sexy 😉

 

Notez cette information
[Total: 1 Average: 5]
Thierry

Thierry

Thierry VANOFFE, consultant, formateur, coach G Suite. Passionné et fasciné par Google, ce blog me permet de partager cette passion et distiller tutos, trucs, astuces, guides sur les outils Google. N'hésitez pas à me solliciter pour vos formations en ligne ou en présentiel.

1 comment

  1. bonjour,
    c’est un bonne alternative mais elle ne fonctionne pas pour les date la formule convertira une date : 22/01/18 par 43453 qui rand la date illisible… et on ne peu pas changé l’écriture de force en date (enfin je ne l’ai pas trouvé si il est possible)

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Share This

Share This

Share this post with your friends!