Google Sheets : corriger l’erreur #N/A avec sierreur

3266 6
L’erreur #N/A indique généralement qu’une formule ne trouve pas ce qu’elle est censée rechercher. L’erreur #N/A survient le plus souvent avec les fonctions RECHERCHEV, RECHERCHEH ou EQUIV si une formule ne trouve pas une valeur référencée. Par exemple, la valeur recherchée n’existe pas dans les données sources.

Dans le cas présent, il n’y a aucune valeur « Banane » dans la table de choix. La fonction RECHERCHEV renvoie donc une erreur #N/A.

Solution : vérifiez que la valeur recherchée existe dans les données sources ou utilisez un gestionnaire d’erreurs tel que SIERREUR dans la formule. Par exemple, =SIERREUR(FORMULE();0) a la signification suivante.

SIERREUR (IFERROR)

S’il ne s’agit pas d’une valeur d’erreur, affiche le premier argument. Sinon, affiche le deuxième argument s’il est présent, ou une valeur vide si cet argument est absent.

Exemple d’utilisation:  =SIERREUR(A1;"Erreur dans la cellule A1")

Vous pouvez utiliser “” pour ne rien afficher ou votre propre texte : =SIERREUR(FORMULE();”Message d’erreur ici”)Dans notre cas :=iferror(VLOOKUP(A2;$D$1:$E$4;2;FALSE);« référence non trouvée »)

Ce qui donne :

Dédicace à Fabrice Faucheux pour cette idée d’article. Maintenant vos recherchev seront encore plus sexy 😉

 

Si vous avez trouvé une faute d’orthographe, veuillez nous en informer en sélectionnant le texte en question et en appuyant sur Ctrl + Entrée .

Thierry

Thierry

Thierry VANOFFE, consultant, formateur, coach G Suite. CEO de Numericoach, leader de la formation G Suite en France. Passionné par Google, ce blog me permet de partager cette passion et distiller tutos, trucs, astuces, guides sur les outils Google. N'hésitez pas à me solliciter pour vos projets de formation.

6 commentaires

  1. Avatar

    Bonjour, la formule ne fonctionne pas lorsque j’ai un cumul du si+recherchev (donc une recherche avec condition) . Quand je rajoute le si erreur encore avant, il me donne un autre code d’erreur: #nom?
    Avez vous une solution pour que si il ne trouve rien comme Info dans case le #N/À n’apparaisse pas, car il empêche un résultat.
    Merci d’avance
    Laurent

    1. Avatar

      Bonjour,
      Vous devez faire une erreur dans votre formulation car le si+recherchev fonctionne très bien.
      attention au tri de la colonne (4eme argument de la fonction) qui mal utilisé provoque l’erreur #N/A
      sinon il existe la fonction ESTNA : qui vérifie si une valeur correspond à cette erreur.
      Salutations
      Gilbert

  2. Avatar

    pour Steeve Savard
    C’est exactement le même principe pour cette fonction
    il faut juste remplacer la virgule par un point virgule en France
    Salutations
    Gilbert

  3. Avatar

    Comment fait-on pour une division?
    J’ai un nombre x dans une cellule
    J’ai un autre nombre x dans une autre cellule

    Disons que je suis dans kla cellule A5
    cellule A2 j’ai le nombre 50
    Cellule A3 j’ai le nombre 10

    Dans Excel j’indiquerais dans la cellule A5 ceci:
    =sierreur(A2/A3,A2) Cette formule permet d’avoir un Zéro à la place de #n/a

    Comment je fait dans sheet pour avoir le même résultat?

    Je me débrouille assez bien dans excel en faisant beaucoup de macro et là, je découvre sheet.
    J’aimerais bien l’apprendre

    Un grand merci!!!!

  4. Avatar

    bonjour,
    c’est un bonne alternative mais elle ne fonctionne pas pour les date la formule convertira une date : 22/01/18 par 43453 qui rand la date illisible… et on ne peu pas changé l’écriture de force en date (enfin je ne l’ai pas trouvé si il est possible)

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Rapport de faute d’orthographe

Le texte suivant sera envoyé à nos rédacteurs :