Google Sheets / Google Finance : connaître la conversion d’une devise à n’importe quelle date

202 0

Dans mon premier article sur Numeriblog, j’aurai le plaisir de vous parler de #Gsheets, #GoogleFinance, #recherchev ; #arrayformula; #ENT

Google sait tout, mémorise tout et parfois partage tout ! Le géant américain met à la disposition du monde l’historique des taux de conversion des devises internationales jour par jour ! 

Contexte 

Vous manipulez un tableau de vente de produits dans une devise (£ par exemple) et vous souhaitez obtenir la conversion dans une autre devise au taux du jour de vente ? Voici pas à pas une proposition de stratégie :

Tableau de bord

Tableau de bord achat de produits en Livres Sterling

Récupérer l’historique des taux de change

Formule GOOGLEFINANCE voir les informations officielles :

Voici en détail la formule qui permet de récupérer la liste des taux de change quotidiens de la Livre Sterling en Euros, depuis le 1er janvier 2020 à aujourd’hui.

=GOOGLEFINANCE("GBPEUR";"price";DATE(2020;1;1);AUJOURDHUI())
=GOOGLEFINANCE(  
"GBPEUR"; coller les codes des devises dans l’ordre de conversion désiré : GBP = £ et EUR = € (donnera le taux de conversion des £ en €)
"price"; attribut de la valeur renvoyée : Price = cours en temps réel (Maj toutes les 20 minutes)
(Voir les autres attributs disponibles)
DATE(2020;1;1); Date initiale du tableau (DATE(ANNEE;MOIS;JOUR)) 
Ici donc à partir du 1er janvier 2020
AUJOURDHUI() Date finale (en indiquant “AUJOURDHUI()” le tableau se mettra à jour  quotidiennement)
)  
Tableau fourni par GoogleFinance

! attention : Google diffuse une information de non responsabilité en cas d’erreur. Les informations ne peuvent être utilisées par des professionnels boursiers.

Créer une colonne qui renvoie la date du jour sans les heures:minutes:secondes

La date du jour est calculée sur le nombre de jours passés depuis le 31/12/1899, puis en décimale sur le nombre de secondes. 

Ainsi le 31 décembre 1899 à 0 heures 0 minutes et 0 secondes est représenté par le nombre 1,00

Google Finance renvoie une date et un horaire, donc un nombre décimal, seule la date du jour nous intéresse, il faut donc extraire la partie entière du nombre (formule ENT())

Extraction de la date fournie par GoogleFinance sous forme dd/mm/aaaa

Rechercher le taux de la date de chaque ligne dans le tableau de bord

Pour finir notre tableau de bord, il faut rechercher le taux de conversion en fonction de la date d’achat du tableau de bord

Exemple dans la cellule G3 de notre tableau de bord :

=RECHERCHEV(C3;TAUX!A:C;3;FALSE)
=RECHERCHEV( Rechercher
C3; la date de la cellule C3
TAUX!A:C; Dans le tableau A:C de la feuille “TAUX” 
3; et renvoie la valeur située dans la 3eme colonne après la A (donc la C)
FALSE en ne donnant pas une valeur approximative
)  

 

Tableau de bord avec la formule RechercheV() dans la première ligne

Étirez la formule ou utilisez un arrayformula pour connaître le taux de chaque jour. Calculez le prix en euros et le total. 

A vous de jouer, en utilisant le service GoogleFinance pour récupérer des données de la Bourse.


Vous avez un projet autour de G Suite
et vous souhaitez nous solliciter :

Formation / développement / interventions…

Antoine MARTIN

Antoine MARTIN

Antoine MARTIN, formateur, consultant en digitalisation, chef de projet et développeur de sites internet. Pour que l'informatique réponde aux besoins de chacun et non le contraire !

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.