ALL Google Sheets

Google Sheets : tout savoir sur les opérateurs.

Ecrit par Thierry

Utilisation d’opérateurs de calcul dans les formules de Google Sheets.

Les opérateurs spécifient le type de calcul à effectuer sur les éléments de la formule. Google Sheets suit les règles mathématiques standard pour l’ordre des calculs, c’est-à-dire, parenthèsesexposantsmultiplications et divisions et additions et soustractions (acronyme PEMDAS). L’utilisation de parenthèses vous permet de modifier l’ordre de ces opérations.

Types d’opérateur. Il existe quatre types d’opérateurs de calcul : arithmétiques, de comparaison, de concaténation de texte et de référence.

  • Opérateurs arithmétiques

    Pour effectuer des opérations mathématiques de base, telles que l’addition, la soustraction, la multiplication ou la division, mais aussi combiner des nombres et produire des résultats numériques, utilisez les opérateurs arithmétiques suivants :

    Opérateur arithmétique Signification Exemple
    + (signe plus) Addition =3+3
    – (signe moins) Soustraction
    Négation
    =3–3
    =-3
    * (astérisque) Multiplication =3*3
    / (barre oblique) Division =3/3
    % (signe pourcentage) Pourcentage 30 %
    ^ (signe insertion) Élévation à la puissance =3^3
  • Opérateurs de comparaison

    Vous pouvez comparer deux valeurs avec les opérateurs ci-dessous. Lorsque deux valeurs sont comparées à l’aide de ces opérateurs, le résultat est une valeur logique — VRAI ou FAUX.

    Opérateur de comparaison Signification Exemple
    = (signe égal) Égal à =A1=B1
    > (signe supérieur à) Supérieur à =A1>B1
    < (signe inférieur à) Inférieur à =A1<B1
    >= (signe supérieur ou égal à) Supérieur ou égal à =A1>=B1
    <= (signe inférieur ou égal à) Inférieur ou égal à =A1<=B1
    <> (signe différent) Différent de =A1<>B1
  • Opérateur de concaténation de texte

    Utilisez le signe  &  pour concaténer (joindre) une ou plusieurs chaînes de texte afin d’obtenir un seul élément de texte.

    Opérateur de texte Signification Exemple
    & (et commercial) Lie, ou concatène, deux valeurs pour produire une valeur de texte continu = »North »& »wind » a pour résultat « Northwind ».
    Si la cellule A1 contient « Nom » et la cellule B1 contient « Prénom », =A1& », « &B1 a pour résultat « Nom, Prénom ».
  • Opérateurs de référence

    Combinez des plages de cellules pour effectuer des calculs à l’aide des opérateurs suivants :

    Opérateurs de référence Signification Exemple
    : (deux-points) Opérateur de plage qui produit une référence à toutes les cellules comprises entre deux références, ces deux références étant incluses B5:B15
    ; (point-virgule) Opérateur d’union qui combine plusieurs références en une seule =SOMME(B5:B15;D5:D15)
Notez cette information
[Total: 2 Average: 5]

A propos de l'auteur

Thierry

Thierry VANOFFE, consultant, formateur, coach G Suite.
Passionné et fasciné par Google, ce blog me permet de partager cette passion et distiller tutos, trucs, astuces, guides sur les outils Google.
N'hésitez pas à me solliciter pour vos formations en ligne ou en présentiel.

Laisser un commentaire

Share This

Share This

Share this post with your friends!